summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHubert Figuiere <hub@figuiere.net>2008-08-12 21:30:02 -0400
committerHubert Figuiere <hub@figuiere.net>2008-08-12 21:30:02 -0400
commit8ddcec9ed725de51d97dccca345e02863746b084 (patch)
tree78d7cd79b45cc32038701ab0d2153b8ed304657b /configure.ac
parentb96e062dce4fd2d0a5921b977ff373a5e8dbabdc (diff)
parent9210d36bdaec85ba3a01c82c71ab39845159bce2 (diff)
Merge branch 'exempi-2.0-branch'
Conflicts: ChangeLog NEWS configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 14b0c84..bf43ba3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,7 @@ dnl 1.99.8 is the revision 4.1.1
dnl 1.99.9 is the revision 4.1.1 (no library change have been made)
dnl 2.0.0 is the revision 4.1.2
dnl 2.0.1 is the revision 4.1.3
+dnl 2.0.2 is the revision 4.1.4
dnl 2.1.0 is the revision 5.2.0
AC_SUBST([EXEMPI_REVISION], [0])
AC_SUBST([EXEMPI_AGE], [2])
@@ -125,6 +126,14 @@ AC_DEFINE_UNQUOTED(ICONV_CONST, $am_cv_proto_iconv_arg1,
[Define as const if the declaration of iconv() needs const.])
dnl end iconv checks
+
+dnl TLS.
+AX_TLS
+if test "$ac_cv_tls" != "none"; then
+ AC_DEFINE(HAVE_NATIVE_TLS, [1], [Define if compiler has native TLS.])
+fi
+dnl end TLS
+
AC_ARG_ENABLE(unittest,
AC_HELP_STRING([--enable-unittest=yes|no],
[enable the unittest. requires boost (default is yes)]),
@@ -198,8 +207,9 @@ exempi/exempi-2.0.pc
echo "
Defines:
- EXEMPI_PLATFORM_DEF = $EXEMPI_PLATFORM_DEF
- CPPFLAGS = $CPPFLAGS
- LDFLAGS = $LDFLAGS
- Run unit test = $ENABLE_UNITTEST
+ EXEMPI_PLATFORM_DEF = $EXEMPI_PLATFORM_DEF
+ CPPFLAGS = $CPPFLAGS
+ LDFLAGS = $LDFLAGS
+ Thread Local Storage = $ac_cv_tls
+ Run unit test = $ENABLE_UNITTEST
"