summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2014-08-12 21:29:50 +0200
committerBenjamin Tissoires <benjamin.tissoires@gmail.com>2014-08-14 11:46:04 -0400
commitb3bf510e829c4982499836770e4667dfe43ad985 (patch)
tree1df99789fb70576312d0e3952ff8f271cf704ace /configure.ac
parentf4a8f7aac81807574b1e22b2e85511c21d14152d (diff)
configure.ac: add '--disable-python-bindings' option
Needed for target systems without python support. Signed-off-by: Peter Seiderer <ps.report@gmx.net> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Benjamin Tissoires <benjamin.tissoires@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 19e1828..cf38ecb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,16 @@ if test "x$XMLTO" = "x" || test "x$ASCIIDOC" = "x"; then
AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
fi
+AC_ARG_ENABLE([python-bindings],
+ AS_HELP_STRING([--disable-python-bindings], [disable generation of python bindings]),
+ [case "${enableval}" in
+ yes) python_bindings=yes ;;
+ no) python_bindings=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --disable-python-bindings]) ;;
+ esac],[python_bindings=yes])
+
+AM_CONDITIONAL(BUILD_PYTHON_BINDINGS, [test "x$python_bindings" = "xyes"])
+
AC_ARG_ENABLE([tests],
AS_HELP_STRING([--disable-tests], [disable building of tests]),
[case "${enableval}" in