summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2019-09-09 14:38:07 +0300
committerPetri Latvala <petri.latvala@intel.com>2019-09-17 13:02:42 +0300
commitddfde25f16ba31fb480d2e83b29631aaa56526cb (patch)
tree041e5c76b531b09bd325ba94bb3eabac0136b21a /meson_options.txt
parentbc11519d627da5a0dd02c43f2912df693dba4cac (diff)
runner: Add support for aborting on network failure
If the network goes down while testing, CI tends to interpret that as the device being down, cutting its power after a while. This causes an incomplete to an innocent test, increasing noise in the results. A new flag to --abort-on-monitored-error, "ping", uses liboping to ping a host configured in .igtrc with one ping after each test execution and aborts the run if there is no reply in a hardcoded amount of time. v2: - Use a higher timeout - Allow hostname configuration from environment v3: - Use runner_c_args for holding c args for runner - Handle runner's meson options in runner/meson.build - Instead of one ping with 20 second timeout, ping with 1 second timeout for a duration of 20 seconds v4: - Rebase - Use now-exported igt_load_igtrc instead of copypaste code - Use define for timeout, clearer var name for single attempt timeout Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Cc: Martin Peres <martin.peres@linux.intel.com> Cc: Tomi Sarvela <tomi.p.sarvela@intel.com> Cc: Daniel Vetter <daniel@ffwll.ch> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 8e2e1cf07..ff3abf084 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -42,6 +42,10 @@ option('runner',
type : 'feature',
description : 'Build test runner')
+option('oping',
+ type : 'feature',
+ description : 'Build test runner with liboping for pinging support')
+
option('use_rpath',
type : 'boolean',
value : false,