summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Zeuthen <david@fubar.dk>2005-06-15 02:31:38 +0000
committerDavid Zeuthen <david@fubar.dk>2005-06-15 02:31:38 +0000
commitb56491eb7a0f524066806c2e8b7a87ca8af45dab (patch)
tree3be452be7b48c962fda5e7f772de13a2ca8d4fa7 /configure.in
parentd1185c83663cd2f3a8265f73fc5d1a0451cfdf4c (diff)
2005-06-14 David Zeuthen <davidz@redhat.com>
* bus/bus.c (process_config_every_time): Drop existing conf-dir watches (if applicable) and add new watches * bus/main.c (signal_handler): Handle SIGIO if using D_NOTIFY (main): Setup SIGIO signal handler if using D_NOTIFY * bus/config-parser.h: Add prototype bus_config_parser_get_conf_dirs * bus/config-parser.c (struct BusConfigParser): Add conf_dirs list (merge_included): Also merge conf_dirs list (bus_config_parser_unref): Clear conf_dirs list (include_dir): Add directory to conf_dirs list (bus_config_parser_get_conf_dirs): New function * bus/dir-watch.[ch]: New files * bus/Makefile.am (BUS_SOURCES): Add dir-watch.[ch] * configure.in: Add checks for D_NOTIFY on Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6da1d95..dca985c 100644
--- a/configure.in
+++ b/configure.in
@@ -7,6 +7,8 @@ AM_INIT_AUTOMAKE(dbus, 0.34)
AM_CONFIG_HEADER(config.h)
+AC_CANONICAL_TARGET
+
# Honor aclocal flags
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
@@ -822,6 +824,22 @@ else
SELINUX_LIBS=
fi
+# dnotify checks
+if test x$target_os = xlinux-gnu; then
+ AC_ARG_ENABLE(dnotify,
+ [ --disable-dnotify Disable using dnotify on Linux],
+ [case "${enableval}" in
+ yes) dnotify=false ;;
+ no) dnotify=true ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-dnotify) ;;
+ esac],[dnotify=true])
+fi
+dnl check if dnotify backend is enabled
+if test x$dnotify = xtrue; then
+ AC_DEFINE(DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX,1,[Use dnotify on Linux])
+fi
+
+
#### Set up final flags
DBUS_CLIENT_CFLAGS=
DBUS_CLIENT_LIBS=