summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-09-05 11:50:38 +0100
committerSimon McVittie <smcv@collabora.com>2022-09-06 00:32:56 +0100
commit0f725f0a534e2592e7c5b99bcb8eae579a3d5232 (patch)
tree0e2dc80bd703285b6dd8518dc38e372b37fc2e2d /pyproject.toml
parent2bc8a75c3e0c76647c49b97f7d2df5a106bf9750 (diff)
setup.py: Build using Meson instead of Autotools by default
This requires mostly dropping support for Python 3.5 and 3.6, both of which are EOL anyway. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3949d8f
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,50 @@
+# Copyright 2022 Collabora Ltd.
+# SPDX-License-Identifier: MIT
+
+[build-system]
+build-backend = 'mesonpy'
+requires = [
+ 'meson-python>=0.8.1',
+ 'meson>=0.60.0',
+ 'ninja',
+ 'patchelf',
+ 'setuptools',
+ 'wheel',
+]
+
+[project]
+name = 'dbus-python'
+license = { text = 'Expat (MIT/X11)' }
+description = 'Python bindings for libdbus'
+maintainers = [
+ { name = 'The D-Bus maintainers', email = 'dbus@lists.freedesktop.org' },
+]
+requires-python = '>=3.7'
+readme = { file = 'README', content-type = 'text/x-rst' }
+keywords = ['dbus', 'D-Bus']
+classifiers = [
+ 'Development Status :: 7 - Inactive',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: C',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Topic :: Software Development :: Object Brokering',
+]
+dynamic = [
+ 'version'
+]
+
+[project.optional-dependencies]
+doc = [
+ 'sphinx',
+ 'sphinx_rtd_theme',
+]
+test = [
+ 'tap.py',
+]
+
+[project.urls]
+homepage = 'http://www.freedesktop.org/wiki/Software/DBusBindings/#python'
+download = 'http://dbus.freedesktop.org/releases/dbus-python/'
+source = 'https://gitlab.freedesktop.org/dbus/dbus-python/'
+tracker = 'https://gitlab.freedesktop.org/dbus/dbus-python/-/issues'