summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-01-29 09:44:28 +0000
committerSimon McVittie <smcv@collabora.com>2018-01-29 09:44:28 +0000
commit660e1b8bb285403a369a46794e6229b906f1ffd3 (patch)
tree0289b973234ba4d3d42dd405d4d7911e0edef946 /configure.ac
parent28098f2c7c23bdef9247c5dfbb8437ca3f03dac4 (diff)
Use system extensions instead of strict C99
Python 3.6 headers cause warnings when using a strict C99 compiler. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40754a1..719a0db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,7 @@ AC_SUBST(DBUS_PYTHON_MICRO_VERSION, dbus_python_micro_version)
AC_CONFIG_SRCDIR([dbus_bindings/module.c])
AC_CONFIG_HEADERS(config.h)
+AC_USE_SYSTEM_EXTENSIONS
AM_INIT_AUTOMAKE([1.13 -Wno-portability subdir-objects tar-ustar])
@@ -199,7 +200,6 @@ AX_COMPILER_FLAGS([WARN_CFLAGS],
-Wno-redundant-decls \
-Wno-switch-default \
-Wno-write-strings \
- -std=c9x \
])
dnl AX_COMPILER_FLAGS doesn't order the compiler flags correctly to be able
dnl to disable flags that it would normally enable