summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-09-05 09:21:38 +0100
committerSimon McVittie <smcv@collabora.com>2022-09-05 17:35:57 +0100
commitfdab4745424c7477e5257a4fc0fff4e14ef664ef (patch)
tree72964414a4d8a49b4456d5f0962ba6925d988543 /Makefile.am
parent29ac041beba6fc299fd4b5434af2382c2473e456 (diff)
Add a Meson build system
Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d7e5975..3b00991 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,8 @@ EXTRA_DIST = \
LICENSES/MIT.txt \
dbus-python.pc.in \
doc/_static/.gitignore \
+ doc/maintainer-update-website.sh \
+ doc/meson.build \
examples/example-async-client.py \
examples/example-client.py \
examples/example-service.py \
@@ -35,8 +37,15 @@ EXTRA_DIST = \
examples/list-system-services.py \
examples/unix-fd-client.py \
examples/unix-fd-service.py \
+ meson.build \
+ meson_options.txt \
setup.py \
test/TestSuitePythonService.service.in \
+ test/compiled.test.in \
+ test/installable/meson.build \
+ test/meson.build \
+ test/py.test.in \
+ test/sh.test.in \
test/tmp-session-bus.conf.in \
tools/check-c-style.sh \
tools/check-coding-style.mk \