summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-12-04 17:56:24 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-10-21 12:37:46 +0100
commit30a03399929cf943449968d537499c63019d36b3 (patch)
tree1a4ee1a650f75a2cab9ba54d454d971a86c1aeea /Makefile.am
parent45869f2d43de75c3fef4b3f5978f096296797257 (diff)
Add infrastructure for running tests under valgrind
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=41129 Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a02699..dd76c7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,4 +50,7 @@ maintainer-upload-release:
rsync -rvzPp --chmod=Dg+s,ug+rwX,o=rX doc/reference/html/ \
dbus.freedesktop.org:/srv/dbus.freedesktop.org/www/doc/@PACKAGE@/
+check-valgrind: all
+ $(MAKE) -C test check-valgrind
+
include tools/lcov.am