summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Taylor <rob.taylor@collabora.co.uk>2006-08-22 12:25:13 +0100
committerRob Taylor <rob.taylor@collabora.co.uk>2006-08-22 12:25:13 +0100
commit27e76bb78db2b467ce93fa0088c6c2407836e4ff (patch)
tree2932d3c5ba90e082fba93828dbb83ac11f6010ee /Makefile.am
parentd49a2a2486cd60e22b360dda8ae5a50d25486667 (diff)
Combine .PHONY rules in toplevel Makefile.am
A .PHONY rule was added by the gtk-doc patch, this combines it with the existsing .PHONY rule
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 41370ca..17001c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,6 @@ MAINTAINERCLEANFILES = ChangeLog
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
EXTRA_DIST += ChangeLog
-.PHONY: ChangeLog $(srcdir)/ChangeLog
ChangeLog: $(srcdir)/ChangeLog
$(srcdir)/ChangeLog:
@if test -d "$(srcdir)/.git"; then \
@@ -48,8 +47,6 @@ clean-bbg:
GCOV_DIRS=$(GLIB_SUBDIR)
-## .PHONY so it always rebuilds it
-.PHONY: coverage-report.txt
coverage-report.txt:
BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg" -o -name "*.gcno"` ; \
C_FILES= ; \
@@ -78,3 +75,5 @@ check-coverage:
echo "Need to reconfigure with --enable-gcov"
endif
+
+.PHONY: ChangeLog $(srcdir)/ChangeLog coverage-report.txt