summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-05-04 18:49:44 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-05-05 16:56:19 +0800
commitb932b8afb69bc62f8639051c605fbeb2b78f1022 (patch)
tree0e6ccd21a261e3cde70783ea9738ce1403abefe6 /meson.build
parent0ce9199ed9c588c19a907ebcd4ce2733d04c2ad9 (diff)
meson: Don't use gendef on Visual Studio
Instead, we use the newly-added CAIROMM_API which is defined to be __declspec(dllexport) to export the symbols directly. This will also allow some cleanup in the Meson build files, as we do not need to differentiate how the cairomm library is built on different compilers.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 28137a7..f6eacd8 100644
--- a/meson.build
+++ b/meson.build
@@ -210,7 +210,7 @@ add_project_arguments(warning_flags, language: 'cpp')
# MSVC: Ignore warnings that aren't really harmful, but make those
# that should not be overlooked stand out.
if is_msvc
- foreach wd : ['/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530', '/utf-8']
+ foreach wd : ['/FImsvc_recommended_pragmas.h', '/wd4251', '/wd4267', '/wd4275', '/wd4530', '/utf-8']
disabled_warning = cpp_compiler.get_supported_arguments(wd)
add_project_arguments(disabled_warning, language: 'cpp')
endforeach
@@ -237,7 +237,6 @@ cairommconfig_h = configure_file(
install_dir: install_includeconfigdir,
)
-subdir('MSVC_NMake/gendef')
subdir('MSVC_NMake/cairomm')
subdir('data')
subdir('cairomm')