summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2021-08-18 08:30:30 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2021-08-18 08:30:30 +0200
commita25dca3c3148f68957d2be01aefce469540cd76b (patch)
tree070e76a81c885d94026ed5ac9f9084441277fe47 /meson.build
parentd6b1c6a047c282b1e33b76bd0f3398d20c03055e (diff)
meson.build: Check if Perl is required for building documentation
New versions of mm-common use the Python scripts doc_postprocess.py and doc_install.py instead of the Perl scripts doc-postprocess.pl and doc-install.pl when documentation is built.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7c5168e..8b18fc2 100644
--- a/meson.build
+++ b/meson.build
@@ -147,7 +147,6 @@ if maintainer_mode and not mm_common_get.found()
mm_common_get = find_program('mm-common-get', required: true)
endif
-perl = find_program('perl', required: build_documentation)
doxygen = find_program('doxygen', required: build_documentation)
dot = find_program('dot', required: build_documentation) # Used by Doxygen
xsltproc = find_program('xsltproc', required: build_documentation)
@@ -175,7 +174,7 @@ dist_changelog_py = script_dir / 'dist-changelog.py'
dist_build_scripts_py = script_dir / 'dist-build-scripts.py'
if maintainer_mode
- # Copy files to untracked/build_scripts and untracked/docs/docs.
+ # Copy files to untracked/build_scripts and untracked/docs.
run_command(mm_common_get, '--force', script_dir,
project_source_root / 'untracked' / 'docs')
else
@@ -191,6 +190,16 @@ sys.exit(os.path.isfile("@0@"))
endif
endif
+# Check if perl is required and available.
+doc_perl_prop = run_command(
+ python3, doc_reference_py, 'get_script_property',
+ '', # MMDOCTOOLDIR is not used
+ 'requires_perl')
+if not (doc_perl_prop.returncode() == 0 and doc_perl_prop.stdout() == 'false')
+ # Perl is required, if documentation shall be built.
+ perl = find_program('perl', required: build_documentation)
+endif
+
# Set compiler warnings.
warning_flags = []
if warning_level == 'min'