summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2021-05-11 11:22:49 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2021-05-11 11:34:21 +0800
commit584b0d1374915ea6128db62c6e2df84dce11e227 (patch)
tree176ac77395e35b479c6d9542094ab0c14c88b2de /meson.build
parent6cff2a3b283d43c5fdfc8588902585c9446cf4d5 (diff)
meson: Reorganize warnings on Visual Studio builds
We can now drop the ignores for warnings C4251, C4273 and C4275 along with C4530, since our code and compiler flags should now make us free of them, since we use /EHsc to build our code and we are clean of classes that we export as a whole that derives from std::xxx classes. Ignore warning C4800, and warning C4127 in the examples, since these warnings are really spurious and safe to ignore as a whole.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c3ba43e..c7f12ef 100644
--- a/meson.build
+++ b/meson.build
@@ -221,7 +221,7 @@ msvc14x_toolset_ver = ''
# MSVC: Ignore warnings that aren't really harmful, but make those
# that should not be overlooked stand out.
if is_msvc
- foreach wd : ['/FImsvc_recommended_pragmas.h', '/wd4251', '/wd4267', '/wd4275', '/wd4530', '/utf-8']
+ foreach wd : ['/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4800', '/utf-8']
disabled_warning = cpp_compiler.get_supported_arguments(wd)
add_project_arguments(disabled_warning, language: 'cpp')
endforeach