summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2021-05-18 10:06:45 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2021-05-18 10:06:45 +0200
commit432005252aaab163bed7eaed19f9fae17b9cf408 (patch)
treec9a1b2832bfe66ff27102ae0ca821aa0d1d7f1f7 /meson.build
parent1a61654874c34a212032a8d337ff64e93bfa1df7 (diff)
Add dependencies to Doxygen tag files in subprojects
Doxygen in a main project shall not be called before tag files have been created or updated in subprojects.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ff7a7cd..7c5168e 100644
--- a/meson.build
+++ b/meson.build
@@ -282,7 +282,7 @@ if can_add_dist_script
]
# Add build scripts to the distribution directory, and delete .gitignore
- # files and an empty $MESON_DIST_ROOT/build/ directory.
+ # files and an empty $MESON_PROJECT_DIST_ROOT/build/ directory.
meson.add_dist_script(
python3.path(), dist_build_scripts_py,
project_source_root,
@@ -298,6 +298,8 @@ if meson.is_subproject()
}
if build_documentation
pkgconfig_vars += {'doxytagfile': tag_file.full_path()}
+ # May be used in a main project.
+ global_tag_file_target = tag_file
endif
cairomm_dep = declare_dependency(
dependencies: cairomm_own_dep,