summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-29 13:27:49 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-29 13:27:49 +0200
commit3d40ff18a50a2a737c7410ee9f611810e82f3f22 (patch)
tree40c5f13df0e79d3d1700fa0fa9aa0b2ea035103f /meson.build
parent87e981ab6d4093e6ae12c8e04dc64265b77f3467 (diff)
Meson build: Fix versioning on macOS
See https://github.com/libsigcplusplus/libsigcplusplus/pull/65
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 943acda..b77991f 100644
--- a/meson.build
+++ b/meson.build
@@ -29,7 +29,12 @@ libtool_soversion = [5, 0, 4]
cairomm_libversion = '@0@.@1@.@2@'.format(
libtool_soversion[0] - libtool_soversion[2],
libtool_soversion[2],
- libtool_soversion[1])
+ libtool_soversion[1]
+)
+macos_darwin_versions = [
+ libtool_soversion[0] + 1,
+ '@0@.@1@'.format(libtool_soversion[0] + 1, libtool_soversion[1])
+]
# Use these instead of meson.source_root() and meson.build_root() in subdirectories.
# source_root() and build_root() are not useful, if this is a subproject.