summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2008-02-18 23:19:53 -0800
committerKeith Packard <keithp@keithp.com>2008-02-18 23:19:53 -0800
commitc1eb987a90b9af10cffa72edd7ae5d8361cd64ce (patch)
tree405ea2b0396f7b755a91743f190e1c4fcd85b9d2 /configure.ac
parent8d5bf62772244a1b19ec942cda7e91da75f29bd6 (diff)
Replace gtk/glib code with pure xlib code.
There's no reason cairo-5c should use gtk/glib; the original plan of wrapping gtk for cairo apps has been supplanted by the nickle-native Chrome toolkit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f2b56c7..455ff29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,7 +50,11 @@ AC_ARG_WITH(nickle-libdir, AS_HELP_STRING([--with-nickle-libdir=LIBDIR],
AC_SUBST(NICKLE_LIBDIR)
AC_SUBST(NICKLE_PATH)
-AC_CHECK_LIB(pthread, pthread_create)
+AC_SEARCH_LIBS(pthread_create, pthread)
+
+AC_SEARCH_LIBS(clock_gettime, rt)
+
+AC_CHECK_FUNCS(clock_gettime)
WARN_CFLAGS=""
@@ -61,7 +65,7 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(WARN_CFLAGS)
-CAIRO_5C_PC_MODULES="cairo cairo-ft fontconfig gtk+-2.0 gthread-2.0"
+CAIRO_5C_PC_MODULES="cairo cairo-ft cairo-xlib x11 fontconfig"
PKG_CHECK_MODULES(CAIRO_5C, $CAIRO_5C_PC_MODULES)