summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Ruiz <alberto.ruiz@sun.com>2007-11-22 16:16:21 +0000
committerAlberto Ruiz <alberto.ruiz@sun.com>2007-11-22 16:16:21 +0000
commitfc0cfe87d04bd6a0bf2b8f1f3f5bfac10d9eff21 (patch)
tree1822268aad6e2bc7ba7f6f4360a3edecc187665e
parentbe1cbf588048e9248335be4b0c716aafc1e22304 (diff)
2007-22-11 Alberto Ruiz <alberto.ruiz@sun.com>
* Added custom package Makefiles to improve the make install procedure.
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac7
-rw-r--r--packages/Evolution1.4_pkg/Makefile.am12
-rw-r--r--packages/Firefox1.5_pkg/Makefile.am22
-rw-r--r--packages/Gnome2.6_pkg/Makefile.am28
-rw-r--r--packages/Makefile.am12
-rw-r--r--packages/StarOffice8_pkg/Makefile.am60
7 files changed, 135 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index be2bcab..cc17fee 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2007-22-11 Alberto Ruiz <alberto.ruiz@sun.com>
+ * Added custom package Makefiles to improve the make install
+ procedure.
+
2007-12-11 Alberto Ruiz <alberto.ruiz@sun.com>
* Added Firefox 1.5 templates.
diff --git a/configure.ac b/configure.ac
index 49a708a..33e52b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,14 @@ AC_INIT(apoc-template-packages, 0.6)
AM_INIT_AUTOMAKE
+PKGSDIR=${datadir}/apoc/packages
+AC_SUBST(PKGSDIR)
+
AC_OUTPUT([
Makefile
packages/Makefile
+packages/Gnome2.6_pkg/Makefile
+packages/Evolution1.4_pkg/Makefile
+packages/Firefox1.5_pkg/Makefile
+packages/StarOffice8_pkg/Makefile
])
diff --git a/packages/Evolution1.4_pkg/Makefile.am b/packages/Evolution1.4_pkg/Makefile.am
new file mode 100644
index 0000000..6fe2fea
--- /dev/null
+++ b/packages/Evolution1.4_pkg/Makefile.am
@@ -0,0 +1,12 @@
+evopkgdir=@PKGSDIR@/Evolution1.4_pkg
+
+evopkg_DATA = \
+ templates/Evolution1.4/Mail/mailTrash.xml \
+ templates/Evolution1.4/Mail/mailComposer.xml \
+ templates/Evolution1.4/Mail/mailDisplay.xml \
+ templates/Evolution1.4/Mail/mailNotifications.xml \
+ templates/Evolution1.4/Mail/mailFormat.xml \
+ templates/Evolution1.4/Mail/mailWarnings.xml \
+ templates/Evolution1.4/Calendar/calTasks.xml \
+ templates/Evolution1.4/Calendar/calDisplay.xml \
+ templates/Evolution1.4/View/viewViewPrefs.xml
diff --git a/packages/Firefox1.5_pkg/Makefile.am b/packages/Firefox1.5_pkg/Makefile.am
new file mode 100644
index 0000000..9d2af7c
--- /dev/null
+++ b/packages/Firefox1.5_pkg/Makefile.am
@@ -0,0 +1,22 @@
+ffoxpkgdir=@PKGSDIR@/Firefox1.5_pkg
+
+ffoxpkg_DATA = \
+ templates/Privacy/privSavedForms.xml \
+ templates/Privacy/privDownloadHistory.xml \
+ templates/Privacy/privCache.xml \
+ templates/Privacy/privPasswords.xml \
+ templates/Privacy/privHistory.xml \
+ templates/Privacy/privSettings.xml \
+ templates/Privacy/privCookies.xml \
+ templates/Advanced/advUpdate.xml \
+ templates/Advanced/advGeneral.xml \
+ templates/Advanced/advSecurity.xml \
+ templates/Tabs/Tabs.xml \
+ templates/Downloads/Downloads.xml \
+ templates/General/genConfigureProxies.xml \
+ templates/General/genHomePage.xml \
+ templates/General/genDefaultBrowser.xml \
+ templates/Content/conJavaScriptAdvanced.xml \
+ templates/Content/conGeneral.xml \
+ templates/Content/conColors.xml \
+ templates/Content/conFonts.xml
diff --git a/packages/Gnome2.6_pkg/Makefile.am b/packages/Gnome2.6_pkg/Makefile.am
new file mode 100644
index 0000000..d42af6a
--- /dev/null
+++ b/packages/Gnome2.6_pkg/Makefile.am
@@ -0,0 +1,28 @@
+gnomepkgdir=@PKGSDIR@/Gnome2.6_pkg
+
+gnomepkg_DATA = \
+ templates/Gnome2.6/RemoteAccess/remoteAccess.xml \
+ templates/Gnome2.6/Keyboard/accessibility.xml \
+ templates/Gnome2.6/Keyboard/keyboardBehavior.xml \
+ templates/Gnome2.6/Keyboard/windowShortcuts.xml \
+ templates/Gnome2.6/Keyboard/desktopShortcuts.xml \
+ templates/Gnome2.6/Keyboard/workspaceShortcuts.xml \
+ templates/Gnome2.6/Keyboard/commandShortcuts.xml \
+ templates/Gnome2.6/Mouse/mouse.xml \
+ templates/Gnome2.6/FolderOptions \
+ templates/Gnome2.6/FolderOptions/folderOptions.xml \
+ templates/Gnome2.6/FolderOptions/folderPreview.xml \
+ templates/Gnome2.6/FolderOptions/folderBehavior.xml \
+ templates/Gnome2.6/Lockdown/desktopLockdown.xml \
+ templates/Gnome2.6/InternetOptions \
+ templates/Gnome2.6/InternetOptions/internetOptions.xml \
+ templates/Gnome2.6/Advanced/panels.xml \
+ templates/Gnome2.6/Advanced/sessions.xml \
+ templates/Gnome2.6/Advanced/preferredApplications.xml \
+ templates/Gnome2.6/CDDeviceOptions/CDDeviceOptions.xml \
+ templates/Gnome2.6/Display/windows.xml \
+ templates/Gnome2.6/Display/displayMenus.xml \
+ templates/Gnome2.6/Display/displayScreen.xml \
+ templates/Gnome2.6/Display/theme.xml \
+ templates/Gnome2.6/Display/background.xml \
+ templates/Gnome2.6/Display/font.xml
diff --git a/packages/Makefile.am b/packages/Makefile.am
index be40adb..9c189c7 100644
--- a/packages/Makefile.am
+++ b/packages/Makefile.am
@@ -1,12 +1,4 @@
-pkgsdir=${datadir}/apoc/packages
+SUBDIRS = Evolution1.4_pkg Firefox1.5_pkg Gnome2.6_pkg StarOffice8_pkg
-dtddir=${pkgsdir}/dtd
+dtddir=@PKGSDIR@/dtd
dtd_DATA = dtd/policytemplate.dtd
-
-
-install-data-local:
- test -z "${pkgsdir}" || mkdir -p "${pkgsdir}"
- cp -r Evolution1.4_pkg/ ${pkgsdir}
- cp -r Gnome2.6_pkg/ ${pkgsdir}
- cp -r Firefox1.5_pkg/ ${pkgsdir}
- cp -r StarOffice8_pkg/ ${pkgsdir}
diff --git a/packages/StarOffice8_pkg/Makefile.am b/packages/StarOffice8_pkg/Makefile.am
new file mode 100644
index 0000000..bc0746c
--- /dev/null
+++ b/packages/StarOffice8_pkg/Makefile.am
@@ -0,0 +1,60 @@
+sopkgdir=@PKGSDIR@/StarOffice8_pkg
+
+sopkg_DATA = \
+ templates/StarOffice8/Drawing/drawPrint.xml \
+ templates/StarOffice8/Drawing/drawGeneral.xml \
+ templates/StarOffice8/Drawing/drawView.xml \
+ templates/StarOffice8/Drawing/drawGrid.xml \
+ templates/StarOffice8/Spreadsheet/ssView.xml \
+ templates/StarOffice8/Spreadsheet/ssCalculate.xml \
+ templates/StarOffice8/Spreadsheet/ssGrid.xml \
+ templates/StarOffice8/Spreadsheet/ssGeneral.xml \
+ templates/StarOffice8/Spreadsheet/ssPrint.xml \
+ templates/StarOffice8/Spreadsheet/ssChanges.xml \
+ templates/StarOffice8/HTMLDocument/htmlBackground.xml \
+ templates/StarOffice8/HTMLDocument/htmlGrid.xml \
+ templates/StarOffice8/HTMLDocument/htmlPrint.xml \
+ templates/StarOffice8/HTMLDocument/htmlView.xml \
+ templates/StarOffice8/HTMLDocument/htmlFormatAids.xml \
+ templates/StarOffice8/HTMLDocument/htmlTable.xml \
+ templates/StarOffice8/LoadSave/lsMSOffice.xml \
+ templates/StarOffice8/LoadSave/lsHTML.xml \
+ templates/StarOffice8/LoadSave/lsGeneral.xml \
+ templates/StarOffice8/LoadSave/lsVBA.xml \
+ templates/StarOffice8/Presentation/presGeneral.xml \
+ templates/StarOffice8/Presentation/presPrint.xml \
+ templates/StarOffice8/Presentation/presGrid.xml \
+ templates/StarOffice8/Presentation/presView.xml \
+ templates/StarOffice8/LanguageSettings/lsLanguages.xml \
+ templates/StarOffice8/LanguageSettings/lsJapaneseSearch.xml \
+ templates/StarOffice8/LanguageSettings/lsAsianLayout.xml \
+ templates/StarOffice8/LanguageSettings/lsCTL.xml \
+ templates/StarOffice8/LanguageSettings/lsWritingAids.xml \
+ templates/StarOffice8/TextDocument/textFonts.xml \
+ templates/StarOffice8/TextDocument/textFormatAids.xml \
+ templates/StarOffice8/TextDocument/textChanges.xml \
+ templates/StarOffice8/TextDocument/textPrint.xml \
+ templates/StarOffice8/TextDocument/textCTLFonts.xml \
+ templates/StarOffice8/TextDocument/textMailMerge.xml \
+ templates/StarOffice8/TextDocument/textView.xml \
+ templates/StarOffice8/TextDocument/textGeneral.xml \
+ templates/StarOffice8/TextDocument/textTable.xml \
+ templates/StarOffice8/TextDocument/textGrid.xml \
+ templates/StarOffice8/TextDocument/textAsianFonts.xml \
+ templates/StarOffice8/Internet/intProxy.xml \
+ templates/StarOffice8/Internet/intMail.xml \
+ templates/StarOffice8/StarOffice/soAppearance.xml \
+ templates/StarOffice8/StarOffice/soGeneral.xml \
+ templates/StarOffice8/StarOffice/soSecurity.xml \
+ templates/StarOffice8/StarOffice/soPrint.xml \
+ templates/StarOffice8/StarOffice/soMemory.xml \
+ templates/StarOffice8/StarOffice/soPaths.xml \
+ templates/StarOffice8/StarOffice/soFonts.xml \
+ templates/StarOffice8/StarOffice/soView.xml \
+ templates/StarOffice8/StarOffice/soAccessibility.xml \
+ templates/StarOffice8/StarOffice/soUserData.xml \
+ templates/StarOffice8/Advanced/advDisableCommands.xml \
+ templates/StarOffice8/Advanced/advImportUserProfile.xml \
+ templates/StarOffice8/Advanced/advGeneral.xml \
+ templates/StarOffice8/Advanced/advDefaultTemplates.xml \
+ templates/StarOffice8/Formula/formSettings.xml