summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75c97f5..0918119 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,11 +58,18 @@ if(LLVM_CMAKE_DIR)
endif()
endif()
+if($ENV{UMR_NEED_RT})
+set(RT_LIBS "-lrt")
+else()
+set(RT_LIBS "")
+endif()
+
set(REQUIRED_EXTERNAL_LIBS
${CURSES_LIBRARIES}
${PCIACCESS_LIBRARIES}
Threads::Threads
${LLVM_LIBS}
+ ${RT_LIBS}
)
# Global setting: build everything position independent