summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2016-09-20 06:51:11 -0700
committerPatrick Ohly <patrick.ohly@intel.com>2016-09-20 06:51:11 -0700
commit499c1c72d5fcf421c18cf2053b24bfda32c6034d (patch)
treef24c03a1705de598d6995010e96428c796055727 /configure.ac
parentbf3c8d5361f5b3b29a7f81235ef9d3d7ff6c5207 (diff)
syncevolution.org: drop binary compatibility hack for old libnotify
syncevolution.org binaries are going to support distros >= Ubuntu Trusty. All of those have libnotify.so.4, so the old binary compatibility hack is no longer needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d6e5e47f..aec73c3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -543,17 +543,6 @@ if test "$enable_dbus_service" != "no"; then
[AC_DEFINE(HAS_NOTIFY, 1,
[define if libnotify could be used in dbus service])])
- AC_ARG_ENABLE(notify-compatibility,
- AS_HELP_STRING([--enable-notify-compatibility],
- [increase compatibility with binary libnotify installations by loading libnotify.so.1..4 dynamically instead of linking against it]),
- [enable_notify_compat="$enableval"],
- [enable_notify_compat="no"]
- )
- if test "$enable_notify_compat" = "yes"; then
- AC_DEFINE(NOTIFY_COMPATIBILITY, 1, [dynamically open libnotify])
- LIBNOTIFY_LIBS="`echo $LIBNOTIFY_LIBS | sed -e 's/\(-lnotify\|[^ ]*libnotify.la\)/-ldl/'`"
- fi
-
# Here we're using QtGui too because mlite fails to depend on it,
# despite using QAction.
PKG_CHECK_MODULES(MLITE, [mlite QtGui], HAVE_MLITE=yes, HAVE_MLITE=no)
@@ -638,7 +627,6 @@ if test "$enable_dbus_service" != "no"; then
;;
esac
fi
-AM_CONDITIONAL([NOTIFY_COMPATIBILITY], [test "$enable_notify_compat" = "yes"])
AM_CONDITIONAL([COND_DBUS_PIM], [test "$enable_dbus_pim" != "no"])
AC_SUBST(DBUS_CFLAGS)