summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2013-11-26 02:12:24 -0800
committerPatrick Ohly <patrick.ohly@intel.com>2013-11-26 17:03:02 +0100
commit06e7d0946f706a5639501ed909788888e0eec1ac (patch)
treec7432ce8e41d4f8c743481cbc354f51ebf616ecd /Makefile.am
parent5e46710ea9bb52a756359cdb9695480f424770f2 (diff)
compatibility hack: support libical.so.1
libical 1.0 changed the library name to libical.so.1, causing dependency problems becaus syncevolution.org binaries required libical.so.0. It turned out that the relevant parts of the API and ABI had not changed, so simply allowing both versions of the library is sufficient. In addition, a detection of libical.so.1 gets added, just in case.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ed83c926..b5d6e5f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,7 +149,7 @@ else
REQUIRES_deb_neon =
endif
if ENABLE_ICAL
-REQUIRES_deb_ical = , libical0
+REQUIRES_deb_ical = , libical0 | libical1
endif
VERSION_deb = 1:$(STABLE_VERSION)$(VERSION)
VERSION_rpm = `echo $(VERSION) | sed -e s/-/_/g`