summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 92e95e68ef..5d85dafc21 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -69,6 +69,15 @@ libn_dhcp4 = static_library(
###############################################################################
+libnm_systemd_common_cflags = [ ]
+
+libnm_systemd_common_cflags += cc.get_supported_arguments([
+ '-Wno-nonnull-compare',
+ '-Wno-calloc-transposed-args',
+])
+
+###############################################################################
+
subdir('libnm-std-aux')
subdir('libnm-glib-aux')
subdir('libnm-log-null')