summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2021-04-29 20:54:13 +0200
committerAleksander Morgado <aleksander@aleksander.es>2021-04-30 11:05:42 +0000
commit0a7bfcfb423f4202b910af7f67563552160edcb4 (patch)
treedab0a05174dd83bb3b18901377c09b5d6ad98b70 /configure.ac
parent25a1b28fbfb398c3981cd1bb7305907119ff351c (diff)
build: require glib 2.56
When using glib < 2.55.1 there was a bug in GLib triggering a huge amount of memory leaks in the normal ModemManager runtime. This has caused multiple issues in multiple setups, and so the best way to make sure it no longer happens is to require 2.56. The 2.56.0 glib version is also the one provided by Ubuntu 18.04 LTS, and so we can now say that this LTS release is the last one we support in newer MM releases. The previous Ubuntu 16.04 LTS is already out of the standard 5-year support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a96fdf29..9e0a7845 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,10 +123,8 @@ dnl-----------------------------------------------------------------------------
dnl Build dependencies
dnl
-# NOTE! If using glib < 2.55.1, make sure you have backported the following patch to avoid
-# the daemon leaking a lot: https://gitlab.gnome.org/GNOME/glib/commit/37d9b0c6995f97ea0f744650aaf5179081f878ba
-GLIB_MIN_VERSION=2.48.0
-GLIB_BUILD_SYMBOLS="-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_48 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_48 -DGLIB_DISABLE_DEPRECATION_WARNINGS"
+GLIB_MIN_VERSION=2.56.0
+GLIB_BUILD_SYMBOLS="-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_56 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_56 -DGLIB_DISABLE_DEPRECATION_WARNINGS"
PKG_CHECK_MODULES(MM,
glib-2.0 >= $GLIB_MIN_VERSION