summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2012-01-09 16:26:27 -0600
committerDan Williams <dcbw@redhat.com>2012-01-09 17:23:42 -0600
commit96210d1c5530aa623f49e1ef19eb44c88f137581 (patch)
tree15411c960fd2e024e62b4c814e1913731bf9a1bf /Makefile.am
parent2f1d8f7fb334ba05fba0676f61333f8246b7e4a5 (diff)
dbus: don't install introspection XML we don't really own
MM implements the DBus properties interface and of course that requires some XML on our side for dbus-glib. But we shouldn't install that along with our ModemManager-specific XML.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d6c2bcba..04885222 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,7 +55,7 @@ include/ModemManager.h: $(XMLS) introspection/all.xml header-generator.xsl
$(edit) $< >$@
xmldir = $(datadir)/dbus-1/interfaces
-xml_DATA = $(filter-out introspection/all.xml, $(XMLS))
+xml_DATA = $(filter-out introspection/all.xml introspection/org.freedesktop.DBus.Properties.xml, $(XMLS))
edit = @sed \
-e 's|@sbindir[@]|$(sbindir)|g' \