summaryrefslogtreecommitdiff
path: root/spa/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2019-08-20 20:35:41 +0200
committerWim Taymans <wtaymans@redhat.com>2019-08-20 20:35:41 +0200
commit5b9869200fcf8841e06f024ad94be8104fd9fba2 (patch)
tree26adc84ab33053085536f385d56059055006ce9c /spa/meson.build
parentd00c641559e85f148241f7b6b3a21b6df807f7cb (diff)
jack: add jack source and sink
Makes a device with a source and sink that automatically proxies all physical ports from jack. Jack then drives our PipeWire pipeline from its own thread.
Diffstat (limited to 'spa/meson.build')
-rw-r--r--spa/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/spa/meson.build b/spa/meson.build
index 6fcfcaa0..42780a8c 100644
--- a/spa/meson.build
+++ b/spa/meson.build
@@ -27,6 +27,9 @@ if get_option('spa-plugins')
avcodec_dep = dependency('libavcodec')
avformat_dep = dependency('libavformat')
endif
+ if get_option('jack')
+ jack_dep = dependency('jack', version : '>= 1.9.10')
+ endif
if get_option('vulkan')
vulkan_dep = dependency('vulkan')
endif