summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2018-10-18 09:50:43 +0200
committerWim Taymans <wtaymans@redhat.com>2018-10-18 12:36:10 +0200
commit88d6e52cc7c08725adebffce8a385496f762aceb (patch)
tree131ff04fe53351806c612516ea441a4531a1df52 /meson.build
parenta086fc5c0c14904b0af93f5447a6ac86efef1b3d (diff)
add systemd socket activation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7f2273e9..00900794 100644
--- a/meson.build
+++ b/meson.build
@@ -125,6 +125,16 @@ if cc.has_function('memfd_create', prefix : '#include <sys/mman.h>', args : [ '-
cdata.set('HAVE_MEMFD_CREATE', 1)
endif
+if get_option('systemd')
+ systemd = dependency('systemd', required: false)
+ systemd_dep = dependency('libsystemd', required: false)
+ if systemd.found()
+ cdata.set('HAVE_SYSTEMD_DAEMON', 1)
+ else
+ warning('Systemd integration was enabled, but systemd is not available')
+ endif
+endif
+
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)