summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRasmus Thomsen <cogitri@exherbo.org>2018-05-19 11:44:28 +0200
committerWim Taymans <wtaymans@redhat.com>2018-08-17 17:52:19 +0200
commite56344e55e8e69fea8bd57c4ed2042a68afe8d11 (patch)
tree44eff0e26c4c751032be8027bf2ba40ab4751e3e /meson.build
parent55cb38d0a828c95c694cc4f97dad440080af0643 (diff)
meson: rename options as per meson's style guide
see https://mesonbuild.com/Style-guide.html
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index becc0e62..491ebc84 100644
--- a/meson.build
+++ b/meson.build
@@ -155,7 +155,7 @@ jack_dep = dependency('jack', version : '>= 1.9.10', required : false)
pulseaudio_dep = dependency('libpulse', version : '>= 11.1', required : false)
-if get_option('enable_gstreamer')
+if get_option('gstreamer')
glib_dep = dependency('glib-2.0', version : '>=2.32.0')
gobject_dep = dependency('gobject-2.0')
gmodule_dep = dependency('gmodule-2.0')
@@ -174,7 +174,7 @@ subdir('pipewire-jack')
subdir('pipewire-pulseaudio')
subdir('alsa-plugins')
-if get_option('enable_docs')
+if get_option('docs')
doxygen = find_program('doxygen', required : false)
if doxygen.found()
subdir('doc')
@@ -183,7 +183,7 @@ if get_option('enable_docs')
endif
endif
-if get_option('enable_man')
+if get_option('man')
xmltoman = find_program('xmltoman', required : false)
if xmltoman.found()
subdir('man')