summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2019-01-08 12:18:45 +0100
committerWim Taymans <wtaymans@redhat.com>2019-01-08 12:18:45 +0100
commitf8556f1a08eb9f1aea34c1aca8b1fc6900ed3211 (patch)
tree551d1e2dcfcd8cbf6c13f47289cbed0e0ae94835 /meson.build
parent3e77e9bf9916c520be24c41b63bd792b590063d6 (diff)
make c++ optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 05481314..0c5fde8d 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('pipewire', ['c', 'cpp' ],
+project('pipewire', ['c' ],
version : '0.2.9',
license : 'MIT',
meson_version : '>= 0.42.0',
@@ -37,6 +37,8 @@ spa_plugindir = join_paths(pipewire_libdir, 'spa')
gnome = import('gnome')
pkgconfig = import('pkgconfig')
+have_cpp = add_languages('cpp', required : false)
+
cc = meson.get_compiler('c')
if cc.get_id() == 'gcc'