summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-01-24 12:01:25 +0000
committerWim Taymans <wim.taymans@gmail.com>2018-01-26 08:51:38 +0100
commitea283387364f5dd7a14e97cae36915c7c8908e5c (patch)
treed36fbbed6a32f2f6ec348382a11103a1f7723501 /meson.build
parentd99f5defa3460f1df92008d45eae8238cd0998db (diff)
build: Optional tools should not be mandatory
Since we're using the `found()` method on tools found via the `find_program()` function, we are expecting them to be optional, but we are not passing `required:false` to ensure that Meson does not bail out when the tool is not found.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index aeaa9680..97c69153 100644
--- a/meson.build
+++ b/meson.build
@@ -167,15 +167,19 @@ subdir('src')
subdir('pkgconfig')
if get_option('enable_docs')
- doxygen = find_program('doxygen')
+ doxygen = find_program('doxygen', required : false)
if doxygen.found()
subdir('doc')
+ else
+ warning('Documentation was enabled, but doxygen is not available')
endif
endif
if get_option('enable_man')
- xmltoman = find_program('xmltoman')
+ xmltoman = find_program('xmltoman', required : false)
if xmltoman.found()
subdir('man')
+ else
+ warning('Man page generation was enabled, but xmltoman is not available')
endif
endif