summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2018-10-29 13:11:38 +0000
committerWim Taymans <wtaymans@redhat.com>2018-10-31 07:54:59 +0000
commitc2cb8e46b981a59911e5f14dc9349561084abf9f (patch)
treed3a91cd041399404fd34e9cc86a8271bc79dcdd4 /meson.build
parent2ff6b22b27dd2c0f32ad5a647d8832d728f875c1 (diff)
Fix build when systemd is found but not libsystemd
Getting the following otherwise: ``` [13/28] Compiling C object 'src/modules/src@modules@@pipewire-module-protocol-native@sha/module-protocol-native.c.o'. FAILED: src/modules/src@modules@@pipewire-module-protocol-native@sha/module-protocol-native.c.o ccache cc -Isrc/modules/src@modules@@pipewire-module-protocol-native@sha -Isrc/modules -I../src/modules -I. -I../ -Ispa/include -I../spa/include -Isrc -I../src -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -std=gnu99 -O2 -g -fPIC -pthread -DHAVE_CONFIG_H -D_GNU_SOURCE -MD -MQ 'src/modules/src@modules@@pipewire-module-protocol-native@sha/module-protocol-native.c.o' -MF 'src/modules/src@modules@@pipewire-module-protocol-native@sha/module-protocol-native.c.o.d' -o 'src/modules/src@modules@@pipewire-module-protocol-native@sha/module-protocol-native.c.o' -c ../src/modules/module-protocol-native.c ../src/modules/module-protocol-native.c:36:10: fatal error: systemd/sd-daemon.h: No such file or directory #include <systemd/sd-daemon.h> ^~~~~~~~~~~~~~~~~~~~~ ```
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 45c50bd3..a65ffcbc 100644
--- a/meson.build
+++ b/meson.build
@@ -128,7 +128,7 @@ endif
if get_option('systemd')
systemd = dependency('systemd', required: false)
systemd_dep = dependency('libsystemd', required: false)
- if systemd.found()
+ if systemd.found() and systemd_dep.found()
cdata.set('HAVE_SYSTEMD_DAEMON', 1)
else
warning('Systemd integration was enabled, but systemd is not available')