summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2019-02-06 13:24:41 +0100
committerWim Taymans <wtaymans@redhat.com>2019-02-06 13:24:41 +0100
commit569cbb48a9463e09167413afd681f5e10a195bc8 (patch)
treea7c14769820f7889b44833d31409e60649fab81d /meson.build
parenta5630507972b32a2adf56a4d95380c5adf260615 (diff)
use SPA_EXPORT to export symbols
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0c5fde8d..2b398b79 100644
--- a/meson.build
+++ b/meson.build
@@ -42,7 +42,11 @@ have_cpp = add_languages('cpp', required : false)
cc = meson.get_compiler('c')
if cc.get_id() == 'gcc'
- add_global_arguments('-Wsign-compare', '-Wimplicit-fallthrough', '-Wpointer-arith', language : 'c')
+ add_global_arguments('-fvisibility=hidden',
+ '-Wsign-compare',
+ '-Wimplicit-fallthrough',
+ '-Wpointer-arith',
+ language : 'c')
endif
cdata = configuration_data()