summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2018-06-01 11:38:18 +0200
committerWim Taymans <wtaymans@redhat.com>2018-06-01 11:38:18 +0200
commit4005cf03e67a825329b1cbf6470928462935f997 (patch)
treee994770482e799bd99bacc91aada8af19d00385b /meson.build
parent46ad3155b51ef0535e98482628105a5058c45ed1 (diff)
meson: add puleaudio library
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f3ceee9c..a771575b 100644
--- a/meson.build
+++ b/meson.build
@@ -150,6 +150,8 @@ dbus_dep = dependency('dbus-1')
#optional dependencies
jack_dep = dependency('jack', version : '>= 1.9.10', required : false)
+pulseaudio_dep = dependency('pulseaudio', version : '>= 11.09', required : false)
+
if get_option('enable_gstreamer')
glib_dep = dependency('glib-2.0', version : '>=2.32.0')
gobject_dep = dependency('gobject-2.0')
@@ -166,6 +168,7 @@ subdir('spa')
subdir('src')
subdir('pkgconfig')
subdir('pipewire-jack')
+subdir('pipewire-pulseaudio')
subdir('alsa-plugins')
if get_option('enable_docs')