summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-05-01 14:36:54 +0200
committerSebastian Dröge <sebastian@centricular.com>2014-05-01 14:36:54 +0200
commitcad1bb32c8dc34290524e029cb27a930eb84fa78 (patch)
treeffcfc1a10e46d5251b27d88d0a84894b08cf924d /configure.ac
parent5681f78362cc2b20b4dd71d1836e25c27e3e410f (diff)
gl: Try harder to load symbols from the correct place
This commit makes the loading of the GModules threadsafe, and always first tries to load the symbol for the GL library that is selected for the current context. Only then it falls back to looking into the current module (NULL), and only as a last resort the context specific function (e.g. eglGetProcAddress()) is called. Also add configure parameters to select the names of the library modules instead of using the defaults, and let the defaults be independent of the G_MODULE_SUFFIX. https://bugzilla.gnome.org/show_bug.cgi?id=728753
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aad766c65..e73032f46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -527,6 +527,12 @@ AC_ARG_ENABLE([opengl],
*) AC_MSG_ERROR([bad value ${enableval} for --enable-opengl]) ;;
esac],[NEED_GL=auto])
+AC_ARG_WITH([opengl-module-name],
+ AS_HELP_STRING([--with-opengl-module-name],[library module name for OpenGL (default: libGL)]))
+if test x$with_opengl_module_name != x; then
+ AC_DEFINE_UNQUOTED(GST_GL_LIBGL_MODULE_NAME, "$with_opengl_module_name", [OpenGL module name])
+fi
+
AC_ARG_ENABLE([gles2],
[ --enable-gles2 Enable OpenGL|ES 2.0 support @<:@default=auto@:>@],
[case "${enableval}" in
@@ -536,6 +542,12 @@ AC_ARG_ENABLE([gles2],
*) AC_MSG_ERROR([bad value ${enableval} for --enable-gles2]) ;;
esac],[NEED_GLES2=auto])
+AC_ARG_WITH([gles2-module-name],
+ AS_HELP_STRING([--with-gles2-module-name],[library module name for GLES2 (default: libGLESv2)]))
+if test x$with_gles2_module_name != x; then
+ AC_DEFINE_UNQUOTED(GST_GL_LIBGLESV2_MODULE_NAME, "$with_gles2_module_name", [GLES2 module name])
+fi
+
AC_ARG_ENABLE([egl],
[ --enable-egl Enable EGL support @<:@default=auto@:>@],
[case "${enableval}" in
@@ -545,6 +557,12 @@ AC_ARG_ENABLE([egl],
*) AC_MSG_ERROR([bad value ${enableval} for --enable-egl]) ;;
esac],[NEED_EGL=auto])
+AC_ARG_WITH([egl-module-name],
+ AS_HELP_STRING([--with-egl-module-name],[library module name for EGL (default: libEGL)]))
+if test x$with_egl_module_name != x; then
+ AC_DEFINE_UNQUOTED(GST_GL_LIBEGL_MODULE_NAME, "$with_egl_module_name", [EGL module name])
+fi
+
AC_ARG_ENABLE([wgl],
[ --enable-wgl Enable WGL support @<:@default=auto@:>@],
[case "${enableval}" in