summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-31 21:34:42 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-31 21:34:42 -0500
commit7ef94c6a0b7d2f7a8c6d03b12262b0b9e57e414c (patch)
tree7260dcd79320bac1ef11330010023ad50b8b86b5 /configure.ac
parenta99164956f1ade01909123ba196ef01282f41675 (diff)
Revert "automake: src/mesa/drivers/osmesa"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1700058338..1353c28c9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,8 +302,6 @@ xnono )
enable_static=yes
;;
esac
-AM_CONDITIONAL(BUILD_STATIC, test "x$enable_static" = xyes)
-AM_CONDITIONAL(BUILD_SHARED, test "x$enable_shared" = xyes)
dnl
dnl mklib options
@@ -1336,9 +1334,6 @@ x16|x32)
AC_MSG_ERROR([OSMesa bits '$osmesa_bits' is not a valid option])
;;
esac
-AM_CONDITIONAL(HAVE_OSMESA8, test "x$osmesa_bits" = x8)
-AM_CONDITIONAL(HAVE_OSMESA16, test "x$osmesa_bits" = x16)
-AM_CONDITIONAL(HAVE_OSMESA32, test "x$osmesa_bits" = x32)
if test "x$enable_osmesa" = xyes; then
# only link libraries with osmesa if shared
@@ -1347,9 +1342,12 @@ if test "x$enable_osmesa" = xyes; then
else
OSMESA_LIB_DEPS=""
fi
+ OSMESA_MESA_DEPS=""
OSMESA_PC_LIB_PRIV="-lm -lpthread $SELINUX_LIBS $DLOPEN_LIBS"
fi
AC_SUBST([OSMESA_LIB_DEPS])
+AC_SUBST([OSMESA_MESA_DEPS])
+AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
dnl
@@ -1934,8 +1932,6 @@ AC_CONFIG_FILES([configs/autoconf
src/mesa/drivers/dri/r200/Makefile
src/mesa/drivers/dri/radeon/Makefile
src/mesa/drivers/dri/swrast/Makefile
- src/mesa/drivers/osmesa/osmesa.pc
- src/mesa/drivers/osmesa/Makefile
tests/Makefile
tests/glx/Makefile])