summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-03-25 14:08:04 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-04-16 16:33:44 +0200
commit37bf7a516353b323a56ceec820930edef9f784f9 (patch)
tree0d1ef0486f53b0aefb00fd2eb8fceb1e562eb032 /configure.ac
parentb9bf6541434cb8fd9f177e6aa45be6eabf19dbe8 (diff)
doc: Generate chunked manual
This commit makes use of a2x in order to generate a chunked manual in addition to the "all in one page" one.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53d05a2..e4ba9b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -425,9 +425,14 @@ if test "x$enable_manual" != "xno"; then
AC_PATH_PROG([ASCIIDOC], [asciidoc])
AS_IF([test -z "$ASCIIDOC" && test "x$enable_manual" = "xyes"],
[AC_MSG_ERROR([asciidoc is missing and build of manual was requested])])
+ AC_PATH_PROG([A2X], [a2x])
+ AS_IF([test -z "$A2X" && test "x$enable_manual" = "xyes"],
+ [AC_MSG_ERROR([a2x is missing and build of manual was requested])])
fi
AS_IF([test -n "$ASCIIDOC"], [have_asciidoc=yes], [have_asciidoc=no])
-AM_CONDITIONAL([BUILD_MANUAL], [test -n "$ASCIIDOC"])
+AM_CONDITIONAL([BUILD_MANUAL], [test -n "$ASCIIDOC" || test -n "$A2X"])
+AM_CONDITIONAL([BUILD_HTML_MANUAL], [test -n "$ASCIIDOC"])
+AM_CONDITIONAL([BUILD_CHUNKED_MANUAL], [test -n "$A2X"])
dnl ===========================================================================