summaryrefslogtreecommitdiff
path: root/randr/Makefile.am
diff options
context:
space:
mode:
authorLuo Jie <luojie@nlsde.buaa.edu.cn>2007-05-24 11:01:15 -0700
committerEric Anholt <eric@anholt.net>2007-05-24 11:20:59 -0700
commit1f48995d66c0072caa7e5ce2845be642221dd56d (patch)
tree5da0a5ac6f114901b275448ec36a2b8e1a2fa33b /randr/Makefile.am
parent8f98be7db303bc3db650054efb86843c70114451 (diff)
Fix build of composite, dix, and randr when Xinerama is disabled.
Diffstat (limited to 'randr/Makefile.am')
-rw-r--r--randr/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/randr/Makefile.am b/randr/Makefile.am
index 9bf0e6531..20b0f72e0 100644
--- a/randr/Makefile.am
+++ b/randr/Makefile.am
@@ -2,6 +2,8 @@ noinst_LTLIBRARIES = librandr.la
AM_CFLAGS = $(DIX_CFLAGS)
+XINERAMA_SRCS = rrxinerama.c
+
if XORG
sdk_HEADERS = randrstr.h
endif
@@ -18,5 +20,9 @@ librandr_la_SOURCES = \
rrpointer.c \
rrproperty.c \
rrscreen.c \
- rrsdispatch.c \
- rrxinerama.c
+ rrsdispatch.c
+
+if XINERAMA
+librandr_la_SOURCES += ${XINERAMA_SRCS}
+endif
+