summaryrefslogtreecommitdiff
path: root/os/Makefile.am
diff options
context:
space:
mode:
authorEamon Walsh <ewalsh@tycho.nsa.gov>2007-08-28 07:25:21 -0400
committerEamon Walsh <ewalsh@moss-charon.epoch.ncsc.mil>2007-08-28 07:25:21 -0400
commit85547073265ae9bc4ae3af920a6d3214fd1ca0c5 (patch)
tree2e720a9d55fe3cf65e735c8ce66866fb8c749d18 /os/Makefile.am
parent860a09cfb8afc0a293c7eb5e01762724eb86847a (diff)
parent7d54399cfdaa7f54e28828267a76b89c4e8e798f (diff)
Merge branch 'master' into XACE-SELINUX
Conflicts: include/miscstruct.h mi/mibstore.c mi/midispcur.c os/Makefile.am
Diffstat (limited to 'os/Makefile.am')
-rw-r--r--os/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/Makefile.am b/os/Makefile.am
index 9dd1b5432..9b8e08d7f 100644
--- a/os/Makefile.am
+++ b/os/Makefile.am
@@ -3,9 +3,9 @@ noinst_LTLIBRARIES = libos.la libcwrapper.la
AM_CFLAGS = $(DIX_CFLAGS)
# FIXME: Add support for these in configure.ac
-SECURERPC_SRCS = rpcauth.c
INTERNALMALLOC_SRCS = xalloc.c
+SECURERPC_SRCS = rpcauth.c
XDMCP_SRCS = xdmcp.c
STRLCAT_SRCS = strlcat.c strlcpy.c
XORG_SRCS = log.c
@@ -27,6 +27,10 @@ libos_la_SOURCES = \
xprintf.c \
$(XORG_SRCS)
+if SECURE_RPC
+libos_la_SOURCES += $(SECURERPC_SRCS)
+endif
+
if XDMCP
libos_la_SOURCES += $(XDMCP_SRCS)
endif