summaryrefslogtreecommitdiff
path: root/os/Makefile.am
diff options
context:
space:
mode:
authorBrian M. Clapper <bmc@clapper.org>2016-07-11 18:30:05 -0400
committerKeith Packard <keithp@keithp.com>2016-07-19 11:08:21 -0700
commit711c36558f50943c8342f25ad210281134887a3d (patch)
tree32332c26febbedf83ae452b0158c9b4662dc500a /os/Makefile.am
parent2a79be9e4dd1b6ba00b69ff40bc5257ec84d34da (diff)
os: Add poll emulation for mingw [v2]
v2: rename as 'xserver_poll' to avoid potential library name collisions. Provide 'xserver_poll.h' which uses the system poll where available and falls back to this emulation otherwise. Autodetects when this is required, building the emulation only then Source: https://github.com/bmc/poll Signed-off-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'os/Makefile.am')
-rw-r--r--os/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/os/Makefile.am b/os/Makefile.am
index fc49a73e3..c449076f8 100644
--- a/os/Makefile.am
+++ b/os/Makefile.am
@@ -7,6 +7,8 @@ XDMCP_SRCS = xdmcp.c
XORG_SRCS = log.c
BUSFAULT_SRCS = busfault.c
+XSERVER_POLL_SRCS=xserver_poll.c
+
libos_la_SOURCES = \
WaitFor.c \
access.c \
@@ -32,6 +34,11 @@ if SECURE_RPC
libos_la_SOURCES += $(SECURERPC_SRCS)
endif
+if POLL
+else
+libos_la_SOURCES += $(XSERVER_POLL_SRCS)
+endif
+
if XDMCP
libos_la_SOURCES += $(XDMCP_SRCS)
endif