summaryrefslogtreecommitdiff
path: root/hw/kdrive/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2003-12-01 04:33:36 +0000
committerEric Anholt <anholt@freebsd.org>2003-12-01 04:33:36 +0000
commit9cdd6fd9e3d6e44adf392279093f92fb6678a49c (patch)
tree47295d996d343c4cc42f37d839e415aac4aa8098 /hw/kdrive/Makefile.am
parentec7f5539302fafd1ac7609ac423f1379f54916ab (diff)
- Add fbdev mode-setting backend to Xati. It and vesa are compiled in when
available, with fbdev being used by default. - Use depth 16 by default when vesa backend is used. - Add MMIO defines for PowerPC (should be in a common location). Many thanks for Michel Daenzer for much of this code.
Diffstat (limited to 'hw/kdrive/Makefile.am')
-rw-r--r--hw/kdrive/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/hw/kdrive/Makefile.am b/hw/kdrive/Makefile.am
index 2d51c9c9d..1ff8a0d50 100644
--- a/hw/kdrive/Makefile.am
+++ b/hw/kdrive/Makefile.am
@@ -1,10 +1,14 @@
if KDRIVEVESA
-VESA_SUBDIRS = vesa ati mach64 mga nvidia r128 smi
+VESA_SUBDIRS = vesa mach64 mga nvidia r128 smi
endif
-SUBDIRS = \
- src \
- linux \
- fbdev \
- $(VESA_SUBDIRS)
+if KDRIVEFBDEV
+FBDEV_SUBDIRS = fbdev
+endif
+SUBDIRS = \
+ src \
+ linux \
+ $(FBDEV_SUBDIRS) \
+ $(VESA_SUBDIRS) \
+ ati