summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2017-03-10 10:43:22 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2017-03-21 16:34:56 +0100
commit844544f8bea342130468ab45a404809fc26e7700 (patch)
tree084b5d4b7ecc0cc60d822a53073011cfa99d9feb /Makefile.am
parent02d42d4f00e48517869efc721abc7c0f1d68299f (diff)
build-sys: Add make check-valgrind target
This allows to run automatically our test-suite with valgrind to test for memory leaks. Signed-off-by: Christophe Fergeau <cfergeau@redhat.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5272d5ae..9a073a12 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,9 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = spice-common server docs tools
+check-valgrind:
+ $(MAKE) -C server check-valgrind
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = spice-server.pc