summaryrefslogtreecommitdiff
path: root/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rest/Makefile.am')
-rw-r--r--rest/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/rest/Makefile.am b/rest/Makefile.am
index f3f8517..b59dd41 100644
--- a/rest/Makefile.am
+++ b/rest/Makefile.am
@@ -66,10 +66,14 @@ Rest-@API_VERSION@.gir: librest-@API_VERSION@.la Makefile
Rest_@API_VERSION_AM@_gir_NAMESPACE = Rest
Rest_@API_VERSION_AM@_gir_VERSION = @API_VERSION@
Rest_@API_VERSION_AM@_gir_LIBS = librest-@API_VERSION@.la
-Rest_@API_VERSION_AM@_gir_FILES = $(addprefix $(top_srcdir)/rest/, $(lib_headers))
+Rest_@API_VERSION_AM@_gir_FILES = \
+ $(lib_headers) \
+ $(filter-out %private.h, $(lib_sources))
Rest_@API_VERSION_AM@_gir_CFLAGS = -I$(top_srcdir)
Rest_@API_VERSION_AM@_gir_INCLUDES = GObject-2.0
Rest_@API_VERSION_AM@_gir_PACKAGES = gobject-2.0 libsoup-2.4 libxml-2.0
+Rest_@API_VERSION_AM@_gir_SCANNERFLAGS = --accept-unprefixed
+Rest_@API_VERSION_AM@_gir_EXPORT_PACKAGES = rest-@API_VERSION@
girdir = $(datadir)/gir-1.0
dist_gir_DATA = $(INTROSPECTION_GIRS)