summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 3ac2af5..7c4486f 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,5 +1,8 @@
-noinst_PROGRAMS = test-raw
+noinst_PROGRAMS = test-raw test-json
+
+AM_CFLAGS = $(GLIB_CFLAGS) $(SOUP_CFLAGS) $(JSON_CFLAGS) -I..
+AM_LDFLAGS = $(GLIB_LIBS) $(SOUP_LIBS) $(JSON_LIBS) ../rest/librest.la
test_raw_SOURCES = test-raw.c
-test_raw_LDADD = $(GLIB_LIBS) $(SOUP_LIBS) ../rest/librest.la
-test_raw_CFLAGS = $(GLIB_CFLAGS) $(SOUP_CFLAGS) -I..
+test_json_SOURCES = test-json.c
+