summaryrefslogtreecommitdiff
path: root/gck/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gck/Makefile.am')
-rw-r--r--gck/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/gck/Makefile.am b/gck/Makefile.am
index 70f1f4f9..c8f44cec 100644
--- a/gck/Makefile.am
+++ b/gck/Makefile.am
@@ -87,3 +87,9 @@ DISTCLEANFILES = \
gck-$(GCK_MAJOR).pc: gck.pc
cp gck.pc gck-$(GCK_MAJOR).pc
+
+symbols: libgck-$(VERSION).symbols
+
+libgck-$(VERSION).symbols: .libs/libgck-@GCK_MAJOR@.so
+ nm -D .libs/libgck-@GCK_MAJOR@.so | grep -F ' T ' | \
+ cut -d ' ' -f 3 | sort > $@