summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2019-08-09 13:25:56 +1000
committerDave Airlie <airlied@redhat.com>2019-08-16 09:00:35 +1000
commitf3af7886fe46706df9d21deb1ccb5de3d04a5507 (patch)
treea42a5e2bb6972438ba1187b7638bec5d8e51ac37 /meson.build
parent78eda70892ebaa03e2c1d87cceb386828a1ce64b (diff)
mesa: add support for CET to x86/x86-64 asm files.
Control-flow enforcement technology is a new instructions on x86 processors to denote where indirect jumps can land. Gcc auto adds the instruction (which encodes as a NOP on older CPUs) to entrypoints but assembler files need manual adding. This adds it to all the entry points in the mesa x86/x86-64 assembler files. This will only happen if mesa is built with the -fcf-protection flag to gcc as some distros are wanting to do. Acked-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9c8768bbad0a..379090fbbf6a 100644
--- a/meson.build
+++ b/meson.build
@@ -1034,7 +1034,7 @@ elif cc.has_header_symbol('sys/mkdev.h', 'major')
pre_args += '-DMAJOR_IN_MKDEV'
endif
-foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h', 'sys/shm.h']
+foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h', 'sys/shm.h', 'cet.h']
if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif