summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-06-25 10:13:17 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-06-28 19:15:18 +0100
commit6227e6faee29e4f857aa3a198302135cdf37c402 (patch)
treeadead51c675671477efc9357c5dece72dde82016 /meson.build
parent5819bc0e5c1802e0c0fb7544468d5ff635e1b268 (diff)
meson: only add empty lines betwen active summary sections
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 6238f98b8cac..432b3f4ea871 100644
--- a/meson.build
+++ b/meson.build
@@ -1544,8 +1544,8 @@ lines = ['',
with_gles2 ? 'yes' : 'no'),
]
-lines += ''
if with_osmesa != 'none'
+ lines += ''
suffix = ''
if with_osmesa == 'gallium'
suffix = '(Gallium)'
@@ -1555,8 +1555,8 @@ else
lines += 'OSMesa: no'
endif
-lines += ''
if with_dri
+ lines += ''
lines += 'DRI platform: ' + with_dri_platform
if dri_drivers.length() != 0 and dri_drivers != ['']
lines += 'DRI drivers: ' + ' '.join(dri_drivers)
@@ -1566,8 +1566,8 @@ if with_dri
lines += 'DRI driver dir: ' + dri_drivers_path
endif
-lines += ''
if with_glx != 'disabled'
+ lines += ''
if with_glx == 'dri'
lines += 'GLX: DRI-based'
elif with_glx == 'xlib'