summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-03-11 12:16:21 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-04-29 11:05:46 +0000
commit8dc8c51ec54f209331d0c1b3a895909787819aa9 (patch)
tree072d321234560c2db1b5573b342bf2dd3c4c4c10 /CMakeLists.txt
parent37d5d77bc1751e6e8f7d9f8c2706868314ec68cb (diff)
cmake: add an option for building GLX tests
Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ae6eb92..5f841175 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,11 @@ find_package(PNG REQUIRED)
find_package(X11)
IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ option(BUILD_GLX_TESTS "Build tests that require GLX" ON)
+ELSE()
+ option(BUILD_GLX_TESTS "Build tests that require GLX" OFF)
+ENDIF()
+IF(BUILD_GLX_TESTS)
pkg_check_modules(GLPROTO REQUIRED glproto)
ENDIF()