summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSreerenj Balachandran <sreerenj.balachandran@intel.com>2015-12-08 00:36:36 +0200
committerVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2016-01-19 12:49:11 +0100
commit258214aa334a82d6ac976414a7d3b181ed071371 (patch)
tree2477d260dcbc5ca7f7559a9154db0a936de30d21 /configure.ac
parent046c880d8aee6fc972ccc8374017bf8b3a2b8d70 (diff)
Remove libvpx submodule
We will be using upstream codecparsers always. No more internal libvpx !
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 861b5cfd..734e1cfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,11 +113,6 @@ AC_ARG_ENABLE(builtin_codecparsers,
[enable built-in codecparsers @<:@default=yes@:>@]),
[], [enable_builtin_codecparsers="yes"])
-AC_ARG_ENABLE(builtin_libvpx,
- AS_HELP_STRING([--enable-builtin-libvpx],
- [enable built-in libvpx @<:@default=yes@:>@]),
- [], [enable_builtin_libvpx="yes"])
-
AC_ARG_ENABLE([encoders],
AS_HELP_STRING([--enable-encoders],
[enable video encoders @<:@default=yes@:>@]),
@@ -153,14 +148,6 @@ AC_ARG_WITH([glapi],
[build with the specified OpenGL APIs @<:@default=default_glapi@:>@]),
[GLAPI="$with_glapi"], [GLAPI=default_glapi])
-
-dnl Check fr YASM
-AC_ARG_VAR([YASM], [Path to yasm program, if any])
-AC_PATH_PROG([YASM], [yasm])
-if test -z "$YASM" -a "$enable_builtin_libvpx" = "yes"; then
- AC_MSG_ERROR([yasm is needed to build libvpx sources])
-fi
-
dnl Check for PATCH
AC_ARG_VAR([PATCH], [Path to patch program, if any])
AC_PATH_PROG([PATCH], [patch])
@@ -378,9 +365,6 @@ AM_CONDITIONAL([USE_LOCAL_CODEC_PARSERS_JPEG],
[test "$ac_cv_have_gst_jpeg_parser" != "yes"])
dnl ... VP8 parser, not upstream yet
-if test "$enable_builtin_libvpx" = "yes"; then
- ac_cv_have_gst_vp8_parser="no"
-fi
AC_CACHE_CHECK([for VP8 parser],
ac_cv_have_gst_vp8_parser, [
saved_CPPFLAGS="$CPPFLAGS"
@@ -399,7 +383,6 @@ AC_CACHE_CHECK([for VP8 parser],
])
AM_CONDITIONAL([USE_LOCAL_CODEC_PARSERS_VP8],
[test "$ac_cv_have_gst_vp8_parser" != "yes"])
-AM_CONDITIONAL([USE_BUILTIN_LIBVPX], [test "$enable_builtin_libvpx" = "yes"])
dnl ... VP9 parser, with required extensions
AC_CACHE_CHECK([for VP9 parser],
@@ -1142,7 +1125,6 @@ debian.upstream/libgstvaapi-x11.install.in
docs/reference/plugins/Makefile
docs/reference/plugins/plugins-docs.xml
ext/Makefile
- ext/libvpx/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile
gst-libs/gst/base/Makefile