summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-01-10 16:43:25 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-01-10 18:12:20 +0000
commit371dfac9776b66cb04c449f4f3e5b5a6ddfa4a5e (patch)
treea6992ad14b52214fc75ad6d06acc36c186f6c9f5 /configure.ac
parent3e1ed6823ff128c73656239dcf2fe0c4589e9f8a (diff)
Check for -Wl,--no-add-needed and add it to AM_LDFLAGS everywhere we compile C
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b3bf1627..e71f481cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,6 +94,12 @@ TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$official_release" = xno],
unused-parameter])
AC_SUBST([ERROR_CFLAGS])
+# these aren't really error flags but they serve a similar purpose for us -
+# making the toolchain stricter
+if test "x$official_release" = xno; then
+ TP_ADD_LINKER_FLAG([ERROR_LDFLAGS], [-Wl,--no-add-needed])
+fi
+
AM_CONDITIONAL([OFFICIAL_RELEASE], [test "x$official_release" = xyes])
AC_ARG_ENABLE(debug,