summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-04-29 03:04:27 +0000
committerTim Janik <timj@src.gnome.org>2001-04-29 03:04:27 +0000
commitabc5cbbe3e1f6e6bdc40d94741713e9efb6d580d (patch)
tree2bd011e12c7e43743dd154d4fd95665791e617e5 /gobject/Makefile.am
parent655d467602853052251c10a24f1b62ed1cf72793 (diff)
made hook ids a gulong.
Sun Apr 29 00:37:34 2001 Tim Janik <timj@gtk.org> * ghook.[hc]: made hook ids a gulong. Sat Apr 28 23:39:42 2001 Tim Janik <timj@gtk.org> * gsignal.[hc]: made signal handler and emission hook ids gulongs. (signal_handlers_foreach_matched_R): only invoke callback for handlers that are not disconnected (id>0). (signal_emit_R): prevent invocation of signal handlers during the emission they were connected within. * glib-mkenums: publically installed perl-script to parse C code enums and generate descriptions thereof. * glib-mkenums.1: assorted man page.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 2e02e112f..c89f13455 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -155,10 +155,12 @@ libgobject_1_3_la_SOURCES = $(gruntime_target_sources)
#
# programs to compile and install
#
-bin_PROGRAMS = gobject-query glib-genmarshal testgruntime
+bin_PROGRAMS = gobject-query glib-genmarshal glib-mkenums
+noinst_PROGRAMS = testgruntime
# source files
gobject_query_SOURCES = gobject-query.c
glib_genmarshal_SOURCES = glib-genmarshal.c
+glib_mkenums_SOURCES = glib-mkenums
testgruntime_SOURCES = testgruntime.c
# link programs against libgobject
progs_LDADD = libgobject-1.3.la $(libglib)
@@ -169,7 +171,7 @@ testgruntime_LDADD = $(progs_LDADD)
#
# manual pages to install
#
-man_MANS = glib-genmarshal.1
+man_MANS = glib-genmarshal.1 glib-mkenums.1
#
# auxillary files
@@ -179,7 +181,8 @@ EXTRA_DIST += \
makefile.msc.in \
gobject.def \
gobject.rc.in \
- glib-genmarshal.1
+ glib-genmarshal.1 \
+ glib-mkenums.1
BUILT_EXTRA_DIST = \
makefile.mingw \