summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-09-17 00:41:39 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-09-17 00:41:39 +0000
commit020b44f5ac1b27e26bbd6da4a6b4c466d36cad78 (patch)
tree5865da447ab5dbfe91dcfbaa6c15e93f30506b1d /gobject/Makefile.am
parent545a6a7616471a11c20d22f2ab1f2f4f621e99d1 (diff)
Add variable for LT_CURRENT minus LT_AGE (the suffix used by libtool on
2001-09-17 Tor Lillqvist <tml@iki.fi> * configure.in: Add variable for LT_CURRENT minus LT_AGE (the suffix used by libtool on Win32 for DLLs). Set variables for the compiled resource files on Windows. Handle the native Win32 gthread stuff. * glib/Makefile.am * gmodule/Makefile.am * gobject/Makefile.am: (Win32) Add minor hacks to link in the object file produced from the resource file. Use the lt-compile-resource script from the build module. The non-hack way would be to teach libtool, autoconf and automake about .rc files (which are a kind of source code, after all, that gets compiled to object files). But then there would be problems for those who wouldn't have bleeding edge auto* and libtool. * glib/glib.def * gobject/gobject.def: Updates. * glib/glib.rc.in * gmodule/gmodule.rc.in * gobject/gobject.rc.in * gthread/gthread.rc.in: Update InternalName and OriginalFilename to match libtool's naming convention for DLLs. * glib/gutils.c: Ditto when constructing the DLL name in the definition for GLIB_LOCALE_DIR. * glib/makefile.mingw.in * gmodule/makefile.mingw.in * gobject/makefile.mingw.in * gthread/makefile.mingw.in: Update import library names.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 952af74a5..b76b3c89e 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -31,7 +31,9 @@ libgobject_1_3_la_LDFLAGS = @STRIP_BEGIN@ \
-export-dynamic $(no_undefined) $(export_symbols) \
@STRIP_END@
-libgobject_1_3_la_LIBADD = $(libglib)
+libgobject_1_3_la_LIBADD = @G_OBJECT_WIN32_RESOURCE@ $(libglib)
+
+libgobject_1_3_la_DEPENDENCIES = @G_OBJECT_WIN32_RESOURCE@
#
# setup source file variables
@@ -197,6 +199,11 @@ glib-mkenums: $(srcdir)/glib-mkenums
fi; \
cp $(srcdir)/glib-mkenums glib-mkenums
+if OS_WIN32
+@G_OBJECT_WIN32_RESOURCE@ : gobject.rc
+ $(top_srcdir)/build/win32/lt-compile-resource gobject.rc @G_OBJECT_WIN32_RESOURCE@
+endif
+
gobject.rc: $(top_builddir)/config.status $(top_srcdir)/gobject/gobject.rc.in
cd $(top_builddir) && CONFIG_FILES=gobject/$@ CONFIG_HEADERS= $(SHELL) ./config.status