summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJ. Ali Harlow <ali@juiblex.co.uk>2005-01-03 00:20:47 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-01-03 00:20:47 +0000
commit572e8b2756707488fa7a1066d16944094b165d66 (patch)
tree751fcf6f45af42552af68eabc07004976869bcc7 /configure.in
parenta8cf492b2c787ab06a71f417ec6da8c63a48cf62 (diff)
Don't use AC_TRY_RUN to test for long long format when using the
2005-01-01 J. Ali Harlow <ali@juiblex.co.uk> * configure.in: Don't use AC_TRY_RUN to test for long long format when using the MSVCRT.DLL runtime since we know the answer anyway and it causes some mild inconvience when cross compiling. * README.win32: Add a reference to the cross compiling section of the reference manual. * docs/reference/glib/cross.sgml: MinGW uses MSVCRT.DLL which requires %I64i instead of %lli. (#161306)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a001976de..700974739 100644
--- a/configure.in
+++ b/configure.in
@@ -533,7 +533,7 @@ else
])
fi
-if test x$ac_cv_sizeof_long_long = x8; then
+if test x$glib_native_win32 != xyes && test x$ac_cv_sizeof_long_long = x8; then
# long long is a 64 bit integer.
AC_MSG_CHECKING(for format to printf and scanf a guint64)
AC_CACHE_VAL(glib_cv_long_long_format,[
@@ -564,7 +564,7 @@ if test x$ac_cv_sizeof_long_long = x8; then
elif test x$ac_cv_sizeof___int64 = x8; then
# __int64 is a 64 bit integer.
AC_MSG_CHECKING(for format to printf and scanf a guint64)
- # We know this is MSVC, and what the formats are
+ # We know this is MSVCRT.DLL, and what the formats are
glib_cv_long_long_format=I64
AC_MSG_RESULT(%${glib_cv_long_long_format}u)
AC_DEFINE(HAVE_LONG_LONG_FORMAT,1,[define if system printf can print long long])