summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@imendio.com>2006-01-25 18:20:28 +0000
committerTim Janik <timj@src.gnome.org>2006-01-25 18:20:28 +0000
commitbd88bf87daa832d83d8f9a19038fc9c873283783 (patch)
treeb98bc5eb9f3a79f0f21f369a736bafc7b3f88d68 /configure.in
parent4ec9e3a40d9c8c979afddb15c5e612af70650721 (diff)
fixed buglets reported by Jens Granseuer in #328254.
Wed Jan 25 19:16:57 2006 Tim Janik <timj@imendio.com> * fixed buglets reported by Jens Granseuer in #328254. * configure.in: free the memory allocated in posix_memalign() tests. * glib/gslice.c: spelling fixes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 20623b8a2..2b1d18132 100644
--- a/configure.in
+++ b/configure.in
@@ -1034,6 +1034,8 @@ AC_CACHE_VAL(glib_cv_compliant_posix_memalign,[
void *mem = 0;
if (posix_memalign (&mem, boundary, size) != 0 || !mem)
exit (1);
+ else
+ free (mem);
}
int main() {
test_memalign ( 128, 128 - 2 * sizeof (void*));